---
title: "Linked Server error when importing Assays - sp_addlinkedserver"
canonical: "https://servicedesk.maxgeo.com/space/DS/1351712770/Linked%20Server%20error%20when%20importing%20Assays%20-%20sp_addlinkedserver"
format: markdown
---
|  |  |  |  |
| --- | --- | --- | --- |
| Application: | DataShed5 | Related Build Number: | 2.3.4 |
| Status: | [Known Issue] |  |  |
|  |  |  |  |

---

**Issue: **Linked Server error when importing Assays when using an alias as the database connection string in the admin portal.

![image-20240730-011704.png](media://e5057915-0ea0-4323-b464-ebc472c51e70)


![image-20240730-010622.png](media://3c1d680d-1620-483a-9bc5-37301ea534c8)

**Cause: **The importing functionality for assay functionality uses common features for the Automatic Assay Loader(AAL). AAL requires the use of a linked server

**Resolution: ** 

Step 1:

On web server create alias in the cliconfig located in below folders:

- C:\Windows\SysWOW64
- C:\Windows\System32

Step 2:

In SQL Server create alias the SQL Server config manager. The Alias shuold match the Alias used on the Web Server

Step 3:

Add in two linked servers in SQL

1. Linked Server name matching the Alias name
2. Linked Server name matching the Servername or Servername\instance if using a named instance

eg:

![image-20240730-012104.png](media://7d7512ba-c084-4139-94a4-aff2d47746b7)

To create a linked server follow the instructions [here](https://maxgeo.atlassian.net/wiki/spaces/MAXGEO/pages/1352105988).

> ⚠️ DB Modification
> ⚠️ 
> ⚠️ Before any change is made to a user database (or system), maxgeo recommends competent staff should follow all standard database change management practices and never make untested changes to a production database.  
> ⚠️ Change, test and document all modifications on a test copy of your database to ensure results are as expected before implementing them on your live database. Always ensure a full backup is available in case rollback is required and follow all company change management procedures and practices.