---
title: "Query Timeout in ConfigManager when Registering a View"
canonical: "https://servicedesk.maxgeo.com/space/DataShed4/1270186144/Query%20Timeout%20in%20ConfigManager%20when%20Registering%20a%20View"
format: markdown
---
**Issue: **When registering a view in ConfigManager an Error Occurs - showing Query timeout expired

![image](media://d4a61d60-8f15-4051-88ba-6b6647da4bb3)


**Cause: **ConfigManager runs the view to obtain the fields for the Sort Order and if the view produces large amount of data it times out before it can complete.

**Resolution: ** If available register the view in DataShed5 Admin otherwise rewrite the view to reduce size