---
title: "Troubleshooting Errors in Grids / Reports from Grids"
canonical: "https://servicedesk.maxgeo.com/space/LC/1263239269/Troubleshooting%20Errors%20in%20Grids%20%2F%20Reports%20from%20Grids"
format: markdown
---
<u>**Problem:**</u>

1. If you are running V1.8.0 and the data relates to Group Reporting data as viewed in QueryBuilder - refer **Cause 4**.
2. Leases loaded directly in to the database (e.g. by way of the Importer tool, or an SQL script) however is not showing in all areas of LeaseControl - refer **Cause 5**.
3. The data within a grid (table of data) does not reflect changes made to the data - start at **Troubleshooting 1** and work your way through.
4. A report that summarises/includes data from a grid (table of data) does not reflect changes made to the data - start at **Troubleshooting 1** and work your way through.
5. The data is there, but it appears to be in the wrong columns - refer **Troubleshooting 3**.
  - This happens a lot - more than just after an upgrade - refer **Cause 4**.
6. I apply custom settings to my grids (e.g. grouping data, reordering columns, hiding/unhiding columns, sorting data, etc.) however I have to redo this each day, as the settings are not remembered - refer **Cause 4**.

<u>**Troubleshooting**</u>

1. Right-click in the grey area above the column headers and select "refresh".  If the error was contained within a report, regenerate the report.
  - This ordinarily resolves the error, noting further information is contained in **Cause 1**.
2. You want to compare 2 different views of the data (e.g. QueryBuilder, or switching between a Browser screen and the individual Lease/Agreement record).  To do this, first close all relevant windows (have a look at what is currently open via the "Windows" menu in the top menu bar) then open the relevant screens again and compare the data.
  - If this resolves the error, you can refer to **Cause 1** for further information.
3. Right-click in the grey area above the column headers and select "reset".  This will return the grid to its default settings and, in doing so, repull the data from the database.
  - If this resolves the error, you can refer to **Cause 2** for further information.
4. Close LeaseControl and reopen.
  - If this resolves the error, you can refer to **Cause 1** for further information.
5. If your data still contains errors, refer **Solution 1**.

<u>**Cause:**</u>

1. Each time you open a new screen, the software pulls the data from the database.  It won't 'repull' (refresh) the data until you tell it to (as per the above instructions) or you close the window and reopen.  Remember: several windows can run at one time - have a look at the "Windows" menu from the menu bar to see how many you currently have open.
2. Particularly at time of upgrading, LeaseControl wants to pull new settings through, however where a grid is 'remembering' a Users preferences, this sometimes interferes with the process of pulling the new settings through.  Therefore resetting the grid will resolve the error.
3. This is a bug in V1.8.0 which has been resolved - refer **Solution 2**.
4. Grid settings are stored in a table in the database.  It's possible that this is not updating correctly, which could cause issues with how data is viewed within the grids - refer **Solution 3**.
5. The Lease Name field has "NULL" in the database rather than being empty - refer **Solution 4**.

<u>**Solution:**</u>

1. Email servicedesk.maxgeo.com noting that we need to know which screens and/or reports have the conflicting data.
  - With a report, ensure you advise of what type of report - e.g. which Report in the Report Designer, or which button you selected to generate a Report, or was it in QueryBuilder?
  - Ensure we know specifically which field, and what the data is meant to be.
  - We will likely request a backup of your database to investigate the matter - so if there is a material lead time in your IT team doing this - perhaps give them a heads up now, understanding we can supply FTP details.
2. Upgrade your LeaseControl system - contact [servicedesk.maxgeo.com](http://servicedesk.maxgeo.com) for the upgrader.
3. Email [servicedesk.maxgeo.com](http://servicedesk.maxgeo.com) requesting an .sql script to clear the saved settings.
4. Email [servicedesk.maxgeo.com](http://servicedesk.maxgeo.com) requesting an .sql script to clear the NULL in the Lease Name.  Be sure to supply us with the relevant list of Leases.  We may require a backup of your database to verify the issue.